Aerospike CE 3.5.15: "Message Without LDT source version Field"


#1

Yesterday we upgraded one of our nodes to 3.5.15. After a night of migrations our logs are flooded with

Aug 25 2015 10:15:50 GMT: INFO (rw): (thr_rw.c::2619) MULTI_OP: Message Without LDT source version Field
Aug 25 2015 10:15:50 GMT: INFO (rw): (thr_rw.c::2619) MULTI_OP: Message Without LDT source version Field
Aug 25 2015 10:15:50 GMT: INFO (rw): (thr_rw.c::2619) MULTI_OP: Message Without LDT source version Field
Aug 25 2015 10:15:50 GMT: WARNING (ldt): (thr_rw.c::4915) Could not find ldt info at prole
Aug 25 2015 10:15:50 GMT: WARNING (rw): (thr_rw.c::5959) MULTI_OP: Internal Error ... Multi Op Message Corrupted 
Aug 25 2015 10:15:50 GMT: INFO (rw): (thr_rw.c::2619) MULTI_OP: Message Without LDT source version Field
Aug 25 2015 10:15:50 GMT: INFO (rw): (thr_rw.c::2619) MULTI_OP: Message Without LDT source version Field
Aug 25 2015 10:15:50 GMT: INFO (rw): (thr_rw.c::2619) MULTI_OP: Message Without LDT source version Field

on every node but the upgraded one. (other nodes are 3.5.9)


#2

stilleto,

Recently we fixed an LDT-related bug which made certain fields optional. 3.5.9 and 3.5.14 disagree on this notion. It is benign message - you can ignore it …

In general, if you are using LDT, please upgrade to >-3.5.15 which has a fix for a known, subtle LDT-related bug.

– R