Aerospike RPMs for CentOS/Redhat/EL 7 require openSSL 1.0.2

Aerospike RPMs for CentOS/Redhat/EL 7 require openSSL 1.0.2

Problem Description:

Installing the Aerospike Server RPM returns a failed dependencies error for OPENSSL_1.0.2:

    $ sudo rpm -ivh /tmp/aerospike-server-enterprise-4.5.3.2-el7/aerospike-server-enterprise-4.5.3.2-1.el7.x86_64.rpm
    error: Failed dependencies:
    libcrypto.so.10(OPENSSL_1.0.2)(64bit) is needed by aerospike-server-enterprise-4.5.3.2-1.el7.x86_64

Explanation:

The EL 7 RPM packages are built with OpenSSL 1.0.2, which is the current shipping package version. If you are running on an older version of EL 7 which uses OpenSSL 1.0.1, the installation will not succeed due to a dependency mismatch. This applies to Aerospike Server versions 4.4.0.6 and above.

Solution:

Please resolve by either updating the OS patches (security or whole release) to a point where OpenSSL 1.0.2 is included, or install OpenSSL 1.0.2 using yum update openssl.

Keywords:

OPENSSL SSL DEPENDENCY CENTOS RHEL

Timestamp

June 10 2019