AttributeError: 'module' object has no attribute 'cluster_cr


#1

From OldForum Postby hdimitriou » Fri Dec 21, 2012 4:45 am

After installing, I am trying use ‘cli’ to add some key-value pairs, but I get the following error: /root : cli -o put -k ttt -v "rwr" Traceback (most recent call last): File “/usr/bin/cli”, line 188, in ? sys.exit(main()) File “/usr/bin/cli”, line 130, in main cluster = citrusleaf.cluster_create() AttributeError: ‘module’ object has no attribute ‘cluster_create’

I also tried inserting the exect lines on your example with the same result. In

Since nothing relevant appears on the log, I guess it has to do with the installation and maybe with some requirements on python? Using a VM with “CentOS release 5.8 (Final)” and Aeropsike seems to start without any errors. hdimitriou


#2

Post by young » Fri Dec 21, 2012 11:24 am

A few questions. What build of the product are you using? The latest community edition build is 85. Is this the file that you downloaded and installed?

citrusleaf-community-server-2.0.23.85-el5.tgz young


Post by kavin » Fri Dec 21, 2012 1:28 pm

You can edit:

/opt/citrusleaf/bin/cli
file and change line 130 from

cluster = citrusleaf.cluster_create() to cluster = citrusleaf.CitrusleafCluster()

or you can uninstall the tools package and re-download the latest trial build from the site again and install it. (Download links have been updated with this fix)


Post by chrise99 » Fri Jan 04, 2013 11:27 am

Thought you’d like to know I had this issue too and fixed it based on info in this post. I downloaded the 30 day eval edition just a few days ago chrise99