# Helm, issue with create trial enterprise cluster

**URL:** <https://discuss.aerospike.com/t/helm-issue-with-create-trial-enterprise-cluster/9722>\
**Category:** General Discussion\
**Created:** [September 8, 2022, 12:45pm UTC](https://discuss.aerospike.com/t/helm-issue-with-create-trial-enterprise-cluster/9722 "2022-09-08T12:45:30Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Allanian](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.aerospike.com/allanian/32/1939_2.png) [@Allanian](https://discuss.aerospike.com/u/Allanian)\
**Post date:** [September 8, 2022, 12:45pm UTC](https://discuss.aerospike.com/t/helm-issue-with-create-trial-enterprise-cluster/9722/1 "2022-09-08T12:45:31Z")

</div>

Hello, was trying to create cluster with helm

```auto
wget https://aerospike-trial-download.s3.us-west-2.amazonaws.com/trial-features.conf -O features.conf
kubectl -n aerospike create secret generic aerospike-license --from-file=features.conf
helm upgrade -i aerospike -n aerospike aerospike/aerospike-cluster -f values_cluster.yaml

```

values.yaml

```auto
commonName: aerocluster
replicas: 1
image:
  repository: aerospike/aerospike-server-enterprise
  tag: 6.0.0.1
imagePullSecrets: {}
podSpec:
  multiPodPerHost: true

aerospikeAccessControl:
  users:
    - name: admin
      secretName: auth-secret
      roles:
        - sys-admin
        - user-admin

aerospikeConfig:
  service:
    feature-key-file: /etc/aerospike/secret/features.conf
  security: {}
  network:
    service:
      port: 3000
    fabric:
      port: 3001
    heartbeat:
      port: 3002
  namespaces:
    - name: gluu
      memory-size: 100000 
      #1073741824 # 1GiB
      replication-factor: 1
      storage-engine:
        type: memory

aerospikeNetworkPolicy: {}
#rackConfig:
# namespaces:
# - gluu
# racks:
# - id: 1
# zone: us-east-2
validationPolicy: {}
seedsFinderServices: {}
operatorClientCert: {}
devMode: false

storage:
  filesystemVolumePolicy:
    cascadeDelete: true
    initMethod: deleteFiles
  volumes:
    - name: workdir
      source:
        persistentVolume:
          storageClass: ebs-sc
          volumeMode: Filesystem
          size: 3Gi
      aerospike:
        path: /opt/aerospike
    - name: aerospike-config-secret
      source:
        secret:
          secretName: aerospike-license
      aerospike:
        path: /etc/aerospike/secret

```

Logs

```auto
2022-09-06T17:16:14.230Z INFO controllers.AerospikeCluster Updating ConfigMap {"aerospikecluster": "default/aerocluster", "ConfigMap": {"namespace": "default", "name": "aerocluster-0"}}
2022-09-06T17:16:14.236Z DEBUG lib.asconfig AerospikeConfig {"aerospikecluster": "default/aerocluster", "config": {"logging":[{"any":"info","name":"console"}],"namespaces":[{"memory-size":100000,"name":"gluu","replication-factor":1,"storage-engine":{"type":"memory"}}],"network":{"fabric":{"port":3001},"heartbeat":{"mode":"mesh","port":3002},"service":{"access-addresses":["<access-address>"],"access-port":3000,"alternate-access-addresses":["<alternate-access-address>"],"alternate-access-port":3000,"port":3000}},"security":{},"service":{"cluster-name":"aerocluster","feature-key-file":"/etc/aerospike/secret/features.conf","node-id":"ENV_NODE_ID"}}, "image": "aerospike/aerospike-server-enterprise:6.0.0.1"}
2022-09-06T17:16:14.236Z DEBUG lib.asconfig AerospikeConfig {"aerospikecluster": "default/aerocluster", "conf": "\nlogging {\n\n console {\n context any info\n }\n}\n\nnamespace gluu {\n memory-size 100000\n replication-factor 1\n storage-engine memory\n}\n\nnetwork {\n\n fabric {\n port 3001\n }\n\n heartbeat {\n mode mesh\n port 3002\n }\n\n service {\n access-address <access-address>\n access-port 3000\n alternate-access-address <alternate-access-address>\n alternate-access-port 3000\n port 3000\n }\n}\n\nsecurity {\n}\n\nservice {\n cluster-name aerocluster\n feature-key-file /etc/aerospike/secret/features.conf\n node-id ENV_NODE_ID\n}\n"}
2022-09-06T17:16:14.262Z INFO controllers.AerospikeCluster Scaling up pods {"aerospikecluster": "default/aerocluster", "currentSz": 0, "desiredSz": 1}
2022-09-06T17:16:14.268Z INFO controllers.AerospikeCluster Removing pvc for removed pods {"aerospikecluster": "default/aerocluster", "pods": []}
2022-09-06T17:16:14.326Z INFO controllers.AerospikeCluster Waiting for statefulset to be ready {"aerospikecluster": "default/aerocluster", "WaitTimePerPod": "3m0s"}
2022-09-06T17:16:16.343Z DEBUG controllers.AerospikeCluster Check statefulSet pod running and ready {"aerospikecluster": "default/aerocluster", "pod": "aerocluster-0-0"}
2022-09-06T17:16:26.350Z DEBUG controllers.AerospikeCluster Check statefulSet pod running and ready {"aerospikecluster": "default/aerocluster", "pod": "aerocluster-0-0"}
2022-09-06T17:16:36.359Z DEBUG controllers.AerospikeCluster Check statefulSet pod running and ready {"aerospikecluster": "default/aerocluster", "pod": "aerocluster-0-0"}
2022-09-06T17:16:36.365Z ERROR controllers.AerospikeCluster Failed to scaleUp StatefulSet pods {"aerospikecluster": "default/aerocluster", "stsName": "aerocluster-0", "error": "failed to wait for statefulset to be ready: statefulSet pod aerocluster-0-0 failed: pod failed message in container aerospike-server: back-off 10s restarting failed container=aerospike-server pod=aerocluster-0-0_default(f107c6f5-ee45-4110-80a1-a0bf5e24cd32) reason: CrashLoopBackOff"}
github.com/aerospike/aerospike-kubernetes-operator/controllers.(*SingleClusterReconciler).reconcileRacks
 /workspace/controllers/rack.go:79
github.com/aerospike/aerospike-kubernetes-operator/controllers.(*SingleClusterReconciler).Reconcile
 /workspace/controllers/reconciler.go:72
github.com/aerospike/aerospike-kubernetes-operator/controllers.(*AerospikeClusterReconciler).Reconcile
 /workspace/controllers/aerospikecluster_controller.go:121
sigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).reconcileHandler
 /go/pkg/mod/sigs.k8s.io/controller-runtime@v0.9.2/pkg/internal/controller/controller.go:298
sigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).processNextWorkItem
 /go/pkg/mod/sigs.k8s.io/controller-runtime@v0.9.2/pkg/internal/controller/controller.go:253
sigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).Start.func2.2
 /go/pkg/mod/sigs.k8s.io/controller-runtime@v0.9.2/pkg/internal/controller/controller.go:214
2022-09-06T17:16:36.365Z ERROR controller-runtime.manager.controller.aerospikecluster Reconciler error {"reconciler group": "asdb.aerospike.com", "reconciler kind": "AerospikeCluster", "name": "aerocluster", "namespace": "default", "error": "failed to wait for statefulset to be ready: statefulSet pod aerocluster-0-0 failed: pod failed message in container aerospike-server: back-off 10s restarting failed container=aerospike-server pod=aerocluster-0-0_default(f107c6f5-ee45-4110-80a1-a0bf5e24cd32) reason: CrashLoopBackOff"}
sigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).processNextWorkItem
 /go/pkg/mod/sigs.k8s.io/controller-runtime@v0.9.2/pkg/internal/controller/controller.go:253
sigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).Start.func2.2
 /go/pkg/mod/sigs.k8s.io/controller-runtime@v0.9.2/pkg/internal/controller/controller.go:214
2022-09-06T17:16:36.365Z INFO controllers.AerospikeCluster Reconciling AerospikeCluster {"aerospikecluster": "default/aerocluster"}

```

---

<div class="post-metadata">

**Author:** ![meher](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.aerospike.com/meher/32/1644_2.png) [@meher](https://discuss.aerospike.com/u/meher)\
**Post date:** [September 12, 2022, 11:10pm UTC](https://discuss.aerospike.com/t/helm-issue-with-create-trial-enterprise-cluster/9722/2 "2022-09-12T23:10:23Z")

</div>

Hum… I am not much familiar with Helm… are you able to have a server start up on its own with that feature file? Anything in terms of logs from the db node itself as it seems Helm is just saying that it didn’t start (or that’s how I am interpreting it).

---

<div class="post-metadata">

**Author:** ![Joe\_Martin](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.aerospike.com/joe_martin/32/1013_2.png) [@Joe\_Martin](https://discuss.aerospike.com/u/Joe_Martin)\
**Post date:** [September 16, 2022, 11:38pm UTC](https://discuss.aerospike.com/t/helm-issue-with-create-trial-enterprise-cluster/9722/3 "2022-09-16T23:38:39Z")

</div>

Since you are trying out enterprise it is likely more straightforward to use the Aerospike Kubernetes Operator to spin up your cluster.

> **[Aerospike Kubernetes Operator | Aerospike Documentation](https://docs.aerospike.com/cloud/kubernetes/operator)**
>
> Learn about the Aerospike Kubernetes Operator.

---

<div class="post-metadata">

**Author:** ![system](https://sea1.discourse-cdn.com/flex019/user_avatar/discuss.aerospike.com/system/32/2274_2.png) [@system](https://discuss.aerospike.com/u/system)\
**Post date:** [September 16, 2023, 11:39pm UTC](https://discuss.aerospike.com/t/helm-issue-with-create-trial-enterprise-cluster/9722/4 "2023-09-16T23:39:26Z")

</div>

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.
