Missing Loopback prevents XDR to connect



If you see the following in your asxdr logs, and if you see that asmonitor is not able to connect.

Dec 03 2014 15:49:35 GMT: INFO (xdr): (xdr.c::1014) Could not get host-information from host port 3000
Dec 03 2014 15:49:35 GMT: INFO (xdr): (xdr.c::3423) Trying to connect to local host. Sleeping 60 secs.

[root@xyz]# asmonitor
citrusleaf tools package not installed ? Using self contained commands

Enter help for commands

request to : 3000 returned error
***error* Failed to connect to any hosts.
Please edit the /root/.asmonitor/asmonitor.conf file with the correct hosts parameter in the [main] section
or provide host connection host:port info via the -h parameter
Aerospike Interactive Shell, version 3.3.19


Confirm if the loopback is set correctly in the ifconfig output:

running shell command: ifconfig 2>/dev/null
eth0      Link encap:Ethernet  HWaddr A0:D3:C1:FA:05:BC  
          inet addr:  Bcast:  Mask:
          RX packets:4648156057 errors:0 dropped:0 overruns:0 frame:856
          TX packets:4372914985 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:689867933995 (642.4 GiB)  TX bytes:1298107254339 (1.1 TiB)

If you find that under ifconfig in your system logs, there is no loop back interface, confirm if it is by design.

This means that the server is not listening at the loopback address. XDR will try to connect to the server using the loopback IP (

Have them check network scripts for your loop back interface. Normally the file name by default should be ifcfg-lo and check if there is a file there, and if there is a file there to see if it’s set to yes on ONBOOT.