Aerospike Connect for Kafka - Outbound 3.0.1 (September 11, 2020)

Aerospike Connect for Kafka - Outbound version 3.0.1 was released on September 11, 2020.

  • New Kafka Outbound Connector for Aerospike Server Enterprise Edition version 5.0 and above.
  • Legacy support for versions of the Aerospike Server Enterprise Edition version 4.9 and below.
    • If using Aerospike Server version 4.9 or below the Legacy connector must be used.
    • WARNING: A serious flaw has been discovered for http v2 in the library used by Aerospike Server Enterprise Edition < 5.0 change notification. http-version MUST be set to v1 to prevent xdr and change notification from being blocked.

Improvements

  • Bundle a default configuration file with the installation package.

Bug Fixes

  • Fail to convert Aerospike record to MessagePack format when setname is missing.
© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.