Aerospike percentage of available writes less even with high Disk space availability


#1

Aerospike version : 3.14 Underlying hard disk : non-SSD

Variable Name   Value
memory-size 5 GB
free-pct-memory 98 %
available_pct   4 %
max-void-time   0 millisec
stop-writes 0
stop-writes-pct 90 %
hwm-breached    true
default-ttl 604,800 sec
max-ttl 315,360,000 sec
enable-xdr  false
single-bin  false
data-in-memory  false

Can anyone help why this issue is coming.

Cross posted here:


#2

Please provide this courtesy when cross-posting:


#3

Well, you’re over your HWM. Your defrag mark is at 50% most likely so it can’t defragment anything now. Your cluster isn’t sized for what you’re putting into it.