Cluster Visibility error


#1
root@host ~ # asadm
Seed:        [('localhost', 3000, 'cluster_a')]
Config_file: /root/.aerospike/astools.conf, /etc/aerospike/astools.conf
Aerospike Interactive Shell, version 0.1.17

Found 2 nodes
Online:  x.x.x.x:3000, y.y.y.y:3000
Cluster Visibility error (Please check services list): x.x.x.x:3000

Why ? I can connect from xx to yy and from yy to xx by any ports . and of course telnet xx 3000 and telnet yy 3000 is working.


Repl-write ack: from non-dest node
#2

Could you run:

asadm -e 'asinfo -v services'

#3
root@host1 ~ # asadm -e 'asinfo -v services'    
Seed:        [('localhost', 3000, 'cluster_a')]
Config_file: /root/.aerospike/astools.conf, /etc/aerospike/astools.conf
host1:3000 (x.x.x.x) returned:
y.y.y.y:3000

host2:3000 (y.y.y.y) returned:
x.x.x.x:3000

#4

Didn’t seem to complain about visibility here - did you happen to run the command while the earlier servers were starting?


#5

There is a known issue where the new config file is pulling default values that are potentially different from before. In this case, the ‘cluster_a’ tls name from the config file may be causing your issue. Can you try either editing your config file to comment this line out, or re-running asadm with “–no-config-file” option.


#6

Yes. This is the problem.

I have edited astools.conf

    [cluster]
   #host = "localhost:cluster_a:3000"    
   host = "127.0.0.1:3000"

#7

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.