Error 20: partition map empty


I have an Aerospike docker installed on one my servers, and all was well till yesterday. All of a sudden I started getting an AerospikeException (Java client) for all the Aerospike operations (get, put, operate). com.aerospike.client.AerospikeException$InvalidNamespace: Error 20: Partition map empty] with root cause

Since, the application was not yet on production, I tried the following this:

  • deleted the sets and bins, recreated it
  • dropped the namespace
  • tried to bring the docker down, and brought it up again But none of these helped me fix the problem.

It perfectly works on localhost.

Finally I deployed the docker on a different server, and it works there too.

Any insights on how do I start looking at this problem ?

  1. Could you share server and client versions?
  2. Was there more lines to that error?

That error occurs when the client is either unable to perform initial connection or the client lost connections to all nodes through some network interruption. All database commands will fail until the partition maps have been received.

There is probably a network or docker configuration issue that prevents contact with the servers. I suggest trying to connect from that client machine/docker instance to the same server IP addresses outside of your application (ping, asinfo, etc…) to verify.


Sorry for the delay in my response. I have changed my server and it is working fine. But I really want to know why did this happen on the old one

Client Version 4.5.0 Server version

There is no additional information on the error.