Failed creating arena stage 0: reached shared memory system


handler » Thu Aug 08, 2013 12:25 pm

Hi I’ve installed Aerospike Storage engine on the one of the OpenVZ containers but when I’ve try to start server, I’ve got error message:

Aug 08 2013 19:14:14 GMT: WARNING (cf:arenax): (arenax.c:537) failed creating arena stage 0: reached shared memory system limit
Aug 08 2013 19:14:14 GMT: CRITICAL GLOBAL (namespace): (base/namespace.c:379) ns bar can't create arena: error creating stage
critical error: backtrace: frame 0 /usr/bin/cld() [0x46fd7e]
critical error: backtrace: frame 1 /usr/bin/cld() [0x40e72d]
critical error: backtrace: frame 2 /usr/bin/cld() [0x403f56]
critical error: backtrace: frame 3 /lib/x86_64-linux-gnu/ [0x7fbd9e1afead]
critical error: backtrace: frame 4 /usr/bin/cld() [0x403bf9]

# free -h
total used free shared buffers cached
Mem: 7.5G 1.6G 5.9G 0B 0B 0B
-/+ buffers/cache: 1.6G 5.9G
Swap: 0B 0B 0B

What wrong ?


young » Wed Aug 14, 2013 10:04 am

This error can occur when you do not have enough memory. The minimum requirements for RAM are 4 GB. While you might be able to do with less for development purposes, if you have 1GB or less, the server will not properly start up.


by handler » Wed Aug 14, 2013 10:48 am

Did you seen information about memory, that was provided? What are you talking about?


by young » Wed Aug 14, 2013 5:19 pm

My apologies. What it looks like is that we are trying to get more shared memory, but there is some limit being hit in the VM. It is hard to say what is causing this, but it could be that OpenVZ has a low limit for this.

We generally do not see this message on bare metal machines, unless they have very small amounts of physical RAM. In your case, the VM itself may have a lot of RAM, but there is something limiting the amount of shared memory.

In checking the following page,

There is reference to shmpages, which controls this. It is possible that this parameter or one related to it is causing the problem.


by handler » Wed Aug 14, 2013 11:48 pm

I would be consider that issue - I’m lazy man. You are right - OpenVZ container limit shared memory. So todo tricks: sudo vzctl set <cont_name> --shmpages 4G:9223372036854775807 Now all ok Thanks!