How do I decrease performance %CPU when running scanall


#1

Hi, I am writing Aerospike Java client with scanAll command to query all data in an Aerospike server ( 3 nodes). However, %CPU is very high - may be 1000-2000% in my server. I try to decrease %CPU by using Thread.sleep(xxx) in Java but the CPU still sometimes reaches over 200-300% ( only 1-10% when Thread.sleep) while scanAll command is running. How can I config aerospike to lower %CPU (over 30-40%CPU) when querying all data using scanAll command. My Aerospike version I am using: Aerospike client: 3.3.0 Aerospike server: 3.13.1 enterprise version

Thanks,


#2

I’ve never seen my aerospike daemon go that high. What kind of machine are you running this on, how much power (CPU/cores/speed)? Are you sure the CPU is increased only during scan, and not any other operation (like migrations)?


#3

Try setting ScanPolicy.concurrentNodes to false to reduce cpu usage.