Nginx crashing while changing the aerospike server ip in the client during runtime


#1

Problem scenario:

I tried to connect to the aerospike server and put data , pointing to a valid aerospike server ip . Keeping the connection persistent, created around 150 concurrent connections and fired 100k requests to the client, as the nginx server has max concurrent connection to 150. While the requests have been firing to the server from the client, I tried to replace the ip in the client with an invalid one; i.e; a server that is not reachable/unavailable. After this the nginx crashed , there were no error logs generated. I tried the same steps with the get request, but that seemed to work fine as expected, the issue seems to occur with the put method soo far. Any help/pointer to solve this issue is much appreciated


#2

I assume you’re using persistent connections. So you change the config for the client to an IP that doesn’t exist, or is it an IP that doesn’t have a running Aerospike node?

With persistent connections the initial client object is stored and reused between connections. I want to verify with you the steps to recreating this crash.


#3

We launched a new Aerospike server and changed the client to point to the new server during runtime.

eg: I used to apache benchmark tool to make sure, the client is occupied with the requests , while changing the ip.

Note: I tried with persistent on . which crashed the server. HipHop VM 3.12.0-dev (rel)


#4

Sorry rbotzer ,

The issue is only with persistent connections. Its working fine with keeping the persistent connection off.