Truncating set doesn't seems free unique bin names

Hi, While trying to insert new records, I got Error 21:

Bin name length greater than 14 characters, or maximum number of unique bin names are exceeded.

bin name length is ok, so I checked the available bin names. running

asinfo -v 'bins/Models'

shows:

bin_names=30116,bin_names_quota=32768....

I truncated the problematic sets (asinfo -v "truncate..."), and indeed set seems to be truncated:

+------------------+-----------------------------+----------------+---------+-------------------+-------------------+-------------------+----------------+------------+
| disable-eviction | ns                          | set-enable-xdr | objects | stop-writes-count | set               | memory_data_bytes | truncate_lut   | tombstones |
+------------------+-----------------------------+----------------+---------+-------------------+-------------------+-------------------+----------------+------------+
| "false"          | "myNameSpace"               | "use-default"  | "0"     | "0"               | "problematicSet"  | "0"               | "387438420311" | "0"        |
+------------------+-----------------------------+----------------+---------+-------------------+-------------------+-------------------+----------------+------------+

but available bins stayed the same. I read How to clear up set and bin names when it exceeds the maximum set limit

SHOW INDEXES Models shows there’s no indexes.

SHOW ROLES returning:

Error: (52) AEROSPIKE_SECURITY_NOT_ENABLED

any idea?

thanks :pray:

my bad, after cold restart (as suggested in the link explaining how to free bin name space) it’s solved. thanks

1 Like