Unable to install aerospike python client on ubuntu 14.04


#1

I am getting the following error when i tried pip install aerospike

/usr/bin/ld: cannot find -lssl

/usr/bin/ld: cannot find -lcrypto

collect2: error: ld returned 1 exit status

error: command ‘x86_64-linux-gnu-gcc’ failed with exit status 1


Cleaning up… Command /usr/bin/python -c “import setuptools, tokenize;file=’/tmp/pip_build_root/aerospike/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-T2qOL3-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip_build_root/aerospike Traceback (most recent call last): File “/usr/local/bin/pip”, line 9, in load_entry_point(‘pip==1.5.6’, ‘console_scripts’, ‘pip’)() File “/usr/local/lib/python2.7/dist-packages/pip/init.py”, line 185, in main return command.main(cmd_args) File “/usr/local/lib/python2.7/dist-packages/pip/basecommand.py”, line 161, in main text = ‘\n’.join(complete_log) UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xe2 in position 8: ordinal not in range(128)

Please let me know if you need any more details from my side.


#2

The error message indicate missing SSL development libraries. For Ubuntu, you can install them using apt-get like this:

sudo apt-get install libssl-dev

#3

Thanks and it worked :slight_smile: