WARN Failed to connect to seed 127.0.0.1:3000. AEROSPIKE_ERR_CLIENT Socket write error: 111

secondary

#1

Hi all! Here is the problem: i have to create database containing 215 million keywords from Yandex search. They are located in .csv file. First of all, i run php script and fill in set in namespace with this keywords. It’s OK. Then, i run script which adds word indexes to each record (keyword) and creates record for each word to provide fast search. After this, i created secondary index for set with keywords based on bin with word indexes (Aerospike::INDEX_TYPE_LIST, Aerospike::INDEX_NUMERIC)

It have been worked great until i restarted aerospike. When i restarted db, it starts to collect primary indexes of all records. It took a few minutes. But whe it started to collect secondary indexes, it hungs for a long time. (100.000 records/minute). I have 215 million records, so it will took a days to collect all secondary indexes in DRAM.

Bacause of this collecting, i can’t connect to aerospike and always get error “Failed to connect” from client library and from command “aql” similarly.

How can i remove set or remove secondary index manually? Thanks a lot!