3.7.4 to 3.9.1.1 upgrade and client/amc/tools compatibility?


#1

Hi all,

I’m planning to rolling upgrade Aerospike clusters from 3.7.4 to 3.9.1.1 because this last one seems the more mature right now. However, which version of C# client, AMC, and Tools go with 3.9.1.1 please? I did not find a table with compatibility of different elements. Is there any?

Thanks!


#2

Clients compatible with 3.7.4 will be compatible with 3.9.1.1.

AMC and Tools (asadm and aql) will need upgraded as many stat names in the server where changed in order to follow a stricter naming convention. The latest versions of amc and tools will also support 3.9.1.1.