As_queue exceptions on Windows

error

#1

Hi Community,

While using Aerospike c libevent client on Windows, I ran into some errors in debug mode. Am I not configuring client correctly?

Runtime exception at as_queue.c line 226:

memcpy(ptr, as_queue_get(queue, queue->head), queue->item_size);

Divsion by zero error at as_queue.c line 34:

return &queue->data[(index % queue->capacity) * queue->item_size];

Thanks


#2

Either queue->capacity is zero or your application compile settings conflict with the aerospike library compile settings.

For example, you should not compile application in debug mode while linking to the release Aerospike.dll. Otherwise, all sorts of corruption can occur.


#3

Hi @yncraig Did you managed to fix this? I get the same error, and crash, when trying to batch read async, on linux.

Program received signal SIGFPE, Arithmetic exception. [Switching to Thread 0x7f5453fff700 (LWP 6887)] 0x00007f5481719ee7 in as_queue_copy (free_old=false, new_capacity=0, queue=0x7f5470000c60) at src/main/aerospike/as_queue.c:53 53 src/main/aerospike/as_queue.c: No such file or directory. (gdb) bt #0 0x00007f5481719ee7 in as_queue_copy (free_old=false, new_capacity=0, queue=0x7f5470000c60) at src/main/aerospike/as_queue.c:clock530:

@Brian How can I increase queue->capacity ? I’m using as_event_create_loops. First call working ok, I’m getting the results. However, when I make the second call to aerospike_batch_read_async my app is crashing with the above error.

I’m using AS 4.3.5 version.

Thanks, Beni.