Bin name problem with 14 characters limitation!


#1

hi all,

I am using Aerospike. I have setup Aerospike server by using Docker images. I build a .NET core C# solution and import Aerospike Client to the solution.

However I got the problem with the following code

AerospikeClient client = new AerospikeClient(“localhost”, 3000);

WritePolicy policy = new WritePolicy();

policy.totalTimeout = 50;

var key = new Key(“test”, “mytest”, “mykey”);

Bin bin = new Bin(“my”, 25555);

client.Put(policy, key, bin);

It throws the exception which si “bin name length greater than 14 characters or maximum bins exceeded”. If I changed the bin name to “mybin” then it works.

I tried to find the problem and fix it but I have no idea why.

This is the first time I use Aerospike so I might make some mistake.

Please could you guys help me?

Cheers.

Thanh


#2

The code you provided works fine. I did have to change those unicode “smart quotes” to regular double quotes (ascii value 34) to get your code to compile.


#3

Unfortunately it did not work in my machine.

Are you using Aerospike docker image and .Net core client package for your project? What is about your Aerospike config? Also, I am coding on Windows 10 with .Net core 2.1 but when I changed to .Net framework 4.6 then it also did not work

Cheers


#4

You said it worked if you changed the bin name from “my” to “mybin”. Is that correct?


#5

It works for mybin and not for my :frowning: