Binary package depends on non-current libcrypto

New to Aerospike, tried to run the binary distribution, but it depends on libcrypto.so.1.0.0, while the current version (which I have installed) is 1.0.2k. OS is RHEL7.

Welcome @ganley, it’s great to have you onboard! Are you getting an error or just making sure it’s ok to run this way? If you’re getting an error - could you share it?

Cheers

Hi! I’m getting an error:

$ sudo ./bin/aerospike start
error: start failed due to an error.
/home/ganley/aerospike/aerospike-server/bin/asd: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

$ ls /usr/lib64/libcrypto*
/usr/lib64/libcrypto.so@  /usr/lib64/libcrypto.so.10@  /usr/lib64/libcrypto.so.1.0.2k*

Starting v4.5.0.24, which was released on March 19, OpenSSL 1.0.2 is in use.

Can you confirm you are using an up to date version?

In case you are using an earlier version my recommendation would be to upgrade to the latest version. But in case you need to use an earlier version, you can try creating a symlink, here’s an example howto.

I followed the directions here: https://www.aerospike.com/docs/operations/install/linux/other

I followed these instructions with CentOS7 (that has OpenSSL 1.0.2k per default) in a Docker container and got the same error, but following the dedicated RedHat Install Guide worked well with the community edition for me.

Could you give it a try?

The whole reason I was using the binary install is that the machines I use are heavily secured and I don’t have the necessary permissions to install anything outside of my home directory.

I can get it installed properly if I decide to use it for real, but I’m not going to do that just to try it out.

Thanks for the clarification. A workaround you could try is to extract (not install) the RPM and replace the asd file in your current setup with the asd file from the RPM.

Hey @ganley, checking in to see whether @kporter’s proposal worked? And here’s another idea - if you have Docker installed, can give the image a try?

© 2021 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.