Problem building Aerospike

Hi, I am using CentOS Linux 7 Download aerospike-server latest from git When I run a make, it is building everything, but at the end while linking it gives the following

aerospike-server/cf/src/alloc.c:111: undefined reference to `je_chunksize_mask'
aerospike-server/cf/src/alloc.c:120: undefined reference to `je_huge_aalloc'

Anything that I am doing wrong, or any file that is missing. I searched the whole repository. The above two functions don’t seem to be defined in any of the files. Kindly help

On another note, when I download the latest pre-built binary files (Centos 7), and try to start aerospike, I get the following error:

./bin/asd: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

When I did some search on the internet, I couldn’t find this file libcrypto.so.1.0.0 anywhere and found that its become obsolete.

Am badly stuck, please help in either of the problems, and I will be through.

Thank you

Looks like you didn’t sync the submodules:

Oh, I doubt OpenSSL is obsolete :wink:. As per the note in the installation documentation, you need to update OpenSSL.

Thank you for your prompt reply. It worked.

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.