Client timeout error on Ubuntu 14.04


#1

Hi, I just start using Aerospike. I’ve installed latest server on ubuntu 14.04, and following the guide to:

aql> insert into test.demo(PK, bin) values (‘key’ , ‘Bin Value’)

OK, 1 record affected.

aql> select * from test.demo

Error: (9) Client timeout: timeout=1000 iterations=1 failedNodes=0 failedConns=0

What could be wrong, thanks.


#2

I built a test environment here. I used Ubuntu 14.4 with the latest version of Aerospike for Ubuntu. The insert went fine, and the query was successful and correct.

I’m curious about when you saw the failure. Was it immediately after you started the node? If you waited a minute or two, does the issue persist?

I know that you said that you had just started using Aerospike, but is there a chance that you have a cluster with two or more nodes, and that the cluster contains data? The reason that I ask is that I wonder if the issue occurred while migrations were in progress?

What else can you tell me about the failure?

Thank you for your time,

-DM


#3

I’m using a single node setup on a local machine. And the error can always reproduce.

Both insert/update/detele works fine,

select with PK like:SELECT * FROM evo.users WHERE PK = ‘u000001’ also works.

but select with no condotion gives me the timeout error (which seems to be the scan operation I suppose)

what else information I can provided? Thanks for the reply.


#4

It is odd that you see a failure on such a basic query.

I tested on Aerospike Community version 3.5.3, and version 3.5.2 of the Aerospike tools. I ran it on Ubuntu 14.4.

Would you run sudo asmonitor -e ‘collectinfo’ and let me know what versions of the server and tools you are using?

When you see the timeout error, is it immediate or does the query run for a while?

Do you have a rough guess about how many records are in the namespace?

Thank you for your time,

-DM


#5

Hy,

I had the same problem as you with a big set. If I tried the “select *” directly from al command line it failed in timeout.
just try to increase the timeout by calling your select from the shell command line :
$ aql -T 3000 -c “select * from .”

It should work.

Emmanuel