Decommissioning a node


#1

Hi,

I have a 3 node cluster running on vagrant boxes all running on E 3.11.0.2 in mesh mode

To decommission a node:

  1. Stopped the node: SUCCESSFUL
  2. Changed the config for the other 2 nodes to not include the stopped node in the mesh-seed-address-port list
  3. Issued tip-clear on the other 2 nodes: SUCCESSFUL
  4. Issued a service-alumni-reset on the other 2 nodes: SUCCESSFUL

I am happy about restarting the 2 nodes already in the cluster to form a 2 node cluster

but when I try to start the stopped node: I get the following error:

vagrant@vagrant-ubuntu-trusty-64:~$ sudo service aerospike start

  • Starting aerospike Jan 23 2017 00:38:40 GMT: FAILED ASSERTION (config): (cfg.c:1349) line 27 :: unknown config parameter name 'mode’ Jan 23 2017 00:38:40 GMT: WARNING (as): (signal.c:153) SIGINT received, shutting down Jan 23 2017 00:38:40 GMT: WARNING (as): (signal.c:156) startup was not complete, exiting immediately

The logs show this:

Jan 22 2017 23:58:42 GMT: INFO (as): (signal.c:193) SIGTERM received, starting normal shutdown Jan 22 2017 23:58:42 GMT: INFO (xdr): (xdr.c:5024) XDR is not running. Jan 22 2017 23:58:42 GMT: INFO (storage): (storage.c:797) initiating storage shutdown … Jan 22 2017 23:58:42 GMT: INFO (storage): (storage.c:808) flushing data to storage … Jan 22 2017 23:58:42 GMT: INFO (storage): (storage.c:825) completed flushing to storage Jan 22 2017 23:58:42 GMT: INFO (as): (as.c:546) finished clean shutdown - exiting

please guide! Regards


#2

okay

found this

http://www.aerospike.com/docs/operations/troubleshoot/startup

please allow me to get back

Thanks


#3

So any solution for this


#4

What does your config file look like? Editing error?


#5

I don’t remember changing any thing

service { user root group root paxos-single-replica-limit 1 # Number of nodes where the replica count is automatically reduced to 1. pidfile /var/run/aerospike/asd.pid service-threads 4 transaction-queues 4 transaction-threads-per-queue 4 proto-fd-max 15000 node-id-interface eth1 }

logging { # Log file must be an absolute path. file /var/log/aerospike/aerospike.log { context any info } }

network { service { address any access-address 172.31.99.128 port 3000 mode mesh port 3002 # Heartbeat port for this node.

            # List one or more other nodes, one ip-address & port per line:
           #mesh-seed-address-port 172.31.99.50 3002
           #mesh-seed-address-port 172.31.99.107 3002
           #mesh-seed-address-port 10.10.10.11 3002
           #mesh-seed-address-port 10.10.10.12 3002
           #mesh-seed-address-port 10.10.10.13 3002
           #mesh-seed-address-port 10.10.10.14 3002
            interval 250
            timeout 10
    }

#6

172.31.99.50 3002 172.31.99.107 3002

are the 2 nodes that are still part of the cluster.


#7

You are missing hearbeat context, assuming you cut and paste exactly what you have.

network { service { address any port 3000 access-addres xxxxx }

heartbeat { mode mesh … and so on. }

fabric { port 3001 } info { port 3003 } }

service context does not have config parameter mode and that is what it is flagging


#8

oh yes

how could I miss that :open_mouth:

thanks @pgupta