Does Aerospike support RedHat 7 and/or Centos 7?


#1

bbulkow » Mon Jun 23, 2014 10:55 pm

Hi,

Does Aerospike support RedHat 7 and/or Centos 7?

It seems the Redhat 6 packages mostly install (require a network address as per the troubleshooting section in 3.3.6), and systemctl says the package hasn’t started when it really has, so Aerospike seems to run, but what is the actual supported status of these distributions?


#2

Re: Redhat 7 / Centos 7 compatibility ? Postby meher » Tue Jun 24, 2014 11:30 am

Thanks for the input. We haven’t yet fully tested those distributions but they are definitely on our roadmap!


#3

I just tried to install Aerospike on CentOS 7. The installation does work, but after started the server, it keeps showing the following warning: Nov 05 2014 16:24:40 GMT: WARNING (as): (signal.c::94) SIGFPE received, aborting Aerospike Community Edition build 3.3.21 Nov 05 2014 16:24:40 GMT: WARNING (as): (signal.c::101) stacktrace: frame 0: /usr/bin/asd(as_sig_handle_fpe+0x59) [0x46764e] Nov 05 2014 16:24:40 GMT: WARNING (as): (signal.c::101) stacktrace: frame 1: /lib64/libc.so.6(+0x35640) [0x7f3dea447640] Nov 05 2014 16:24:40 GMT: WARNING (as): (signal.c::101) stacktrace: frame 2: /usr/bin/asd(as_sindex__defrag_fn+0x197) [0x4aa889] Nov 05 2014 16:24:40 GMT: WARNING (as): (signal.c::101) stacktrace: frame 3: /lib64/libpthread.so.0(+0x7df3) [0x7f3deb0fedf3] Nov 05 2014 16:24:40 GMT: WARNING (as): (signal.c::101) stacktrace: frame 4: /lib64/libc.so.6(clone+0x6d) [0x7f3dea50801d] (repeat for infinite times)

uname -a

Linux SERVER_NAME 3.10.0-123.9.2.el7.x86_64 #1 SMP Tue Oct 28 18:05:26 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


#4

Were you using the “Linux” package for this install or the CentOS 6 package?


#5

I used the “Redhat 6 .rpm packages”. Let me try Linux package. thx


#6

tried to use the “other” package and got the same error.

using the “other” package doesn’t exactly like the document:

  1. aerospike init results as some errors, looks like it fail to set file permission (chmod)
  2. the sys folder with lua scripts are missing so it fails to start. (i copied the folder from rpm install to get it work)

I don’t think the above problems is relevant to the SIGFPE received, aborting problem, however.


#7

Hi Mingfai,

Can I get more detail step on what might caused the issue? Since I was able to get Aerospike running fine and I couldn’t replicate the issue. Also it might help us more if you can give us your configuration of Aerospike?

Jerry


#8

Also one other thing I forgot to ask was, are you using a VM or bare metal for aerospike?

Jerry


#9

bare metal. it’s a PC (not a server grade machine), using consumer grade SSD. Let me know if you want me to dump any system information.

Edited: actually i don’t think it reach the SSD yet. To troubleshoot, I think I tried to disable all namespace so it never touch any SSD.


#10

Actually if you can run the following command

sudo asmonitor -e 'collectinfo'

If Aerospike is not running, you can force it with this command:

sudo asmonitor -e 'collectinfo force'

This will give you a log file at the end, can you attach it to this thread? This will run a script to grab the necessary logs for us to look at whats going on with your machine and Aerospike.


#11

when i try to run asmonitor, i found it works now. no idea why there were problem before.

right after installation, I basically only made a few changes to increase the threads from 4 to 8 (as the machine has 8 cpu core), and reduced the amount of ticker and hist log. service-threads 8 transaction-queues 8 transaction-threads-per-queue 8 ticker-interval 360 hist-track-slice 360 and also remove the two default namespaces and add my own.

anyway, case closed. thx