Enabling security prevents docker aerospike from starting

Hello everyone,

I created a docker setup of Aerospike. I can access it from AMC so I think everything is ok so far. But when I follow this site https://www.aerospike.com/docs/operations/configure/security/access-control/index.html to enable security I have to add

security { 
     enable-security true
}

to aerospike.conf. I added to the end of the file. Now the docker container is not starting anymore.

Mounting an external volume for log files works without the security option, but with it not even a log file is created.

What have I done wrong?

Thanks for any hints,

Gernot

There should be a related warning in the Aerospike logs, could you share it?

Also, are you using Aerospike Enterprise or Community? Security is an enterprise feature.

With security option the logs are not even generated. I started to use Aerospike Community. If truly this security option is not available in the community version this is really sad and a no go for further use. Or are there other (outside) techniques to restrict access to the database?

You reach our enterprise sales at https://www.aerospike.com/forms/contact-us/.


You can restrict port access with iptables, which you probably should on most services, with or without the security option.

You could also use a vpn or ipsec between clients and servers for encryption.

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.