Error when running the latest Node.js release

container
docker

#1

Hi

We started using the latest aerospike node.js library v.1.0.38

When connecting to a remote test server running aerospike server 3.5.9 and running some unit tests, we see the following 2 error messages:

[Error: error retrieving scores [{“ns”:“namespace-test”,“set”:“dmp-opt-score-autoscaler-2015-04”,“key”:“86dabeab97c985b4bb7bdb3dd53f8d68”},{“ns”:“namespace-test”,“set”:“dmp-opt-score-autoscaler-2015-04”,“key”:“dc592c8c29a9f1332db4deb8522db9b8”}] {“code”:-1,“message”:“Bad file descriptor”,“func”:“as_socket_read_limit”,“file”:“src/main/aerospike/as_socket.c”,“line”:413}]

[Error: error retrieving referrer {“ns”:“namespace-test”,“set”:“referer-segments-autoscaler-2015-04”,“key”:“08f0613683fb30e27fa431a9f8c416ac682f58dh”,“digest”:[135,223,52,153,0,185,38,85,183,98,229,32,232,246,239,34,185,177,15,32]} {“code”:9,“message”:“Client timeout: timeout=10 iterations=1 failedNodes=0 failedConns=0”,“func”:“as_command_execute”,“file”:“src/main/aerospike/as_command.c”,“line”:445}]

Please note that when running the same unit tests against aerospike server running locally within docker, we do not see the issue.

Please would you be able to provide some information on what is going on?

Thank you so much


#2

Hi mlabour,

Thank you for notifying us about these errors. We will look into them and report back.

Regards,

Maud


#3

Hi Mlabour,

The issue reported seems to be Aerospike Timeout error. If you run the same test in your locally, this timeout problem might not happen, thus you would not observe the same. Can you increase the timeout parameter either through policy value for the operation? Another way to increase the timeout is, to set a global timeout for all the operations. here is the link to set global timeout.

Thanks


#4

Hi gayathri Increasing the timeout did solve the issue. Thank you! -matthieu