Failed Dependency while installing Aerospike Enterprise 4.5.3.5-el7 even when dependency present

Hi,

Getting below error while installing Aerospike:

Checking dependencies

Installing tools

rpm -Uvh aerospike-tools-3.19.0-1.el7.x86_64.rpm error: Failed dependencies:

/usr/bin/python is needed by aerospike-tools-3.19.0-1.el7.x86_64
libcrypto.so.10()(64bit) is needed by aerospike-tools-3.19.0-1.el7.x86_64
libcrypto.so.10(libcrypto.so.10)(64bit) is needed by aerospike-tools-3.19.0-1.el7.x86_64
libhistory.so.6()(64bit) is needed by aerospike-tools-3.19.0-1.el7.x86_64
libreadline.so.6()(64bit) is needed by aerospike-tools-3.19.0-1.el7.x86_64
libssl.so.10()(64bit) is needed by aerospike-tools-3.19.0-1.el7.x86_64
libssl.so.10(libssl.so.10)(64bit) is needed by aerospike-tools-3.19.0-1.el7.x86_64
python is needed by aerospike-tools-3.19.0-1.el7.x86_64

Installing server

rpm -Uvh aerospike-server-enterprise-4.5.3.5-1.el7.x86_64.rpm

error: Failed dependencies:

/usr/bin/python is needed by aerospike-server-enterprise-4.5.3.5-1.el7.x86_64
libcrypto.so.10()(64bit) is needed by aerospike-server-enterprise-4.5.3.5-1.el7.x86_64
libcrypto.so.10(OPENSSL_1.0.2)(64bit) is needed by aerospike-server-enterprise-4.5.3.5-1.el7.x86_64
libcrypto.so.10(libcrypto.so.10)(64bit) is needed by aerospike-server-enterprise-4.5.3.5-1.el7.x86_64
libssl.so.10()(64bit) is needed by aerospike-server-enterprise-4.5.3.5-1.el7.x86_64
libssl.so.10(libssl.so.10)(64bit) is needed by aerospike-server-enterprise-4.5.3.5-1.el7.x86_64

Python 2.7.15 and OpenSSL 1.1.1 FIPS 11 Sep 2018 are installed.

OS: RedHat 8.0

For the first one, does this article help: Tools install fails on Amazon Linux with Python error?

For the second one, this should help: Aerospike RPMs for CentOS/Redhat/EL 7 require openSSL 1.0.2.

Thanks. First one works fine. Do we have to downgrade OpenSSL from 1.1.1 to 1.0.2. Any work around possible ?

I’m not familiar with RHEL, but can’t you install both at the same time, 1.1.1 as well as 1.0.2?

From the error messages that you provided it seems that the names of the missing 1.0.2 libraries are libcrypto.so.10 and libssl.so.10. My guess would be that RHEL uses a versioned naming scheme for its shared libraries, so that different versions can coexist. I’d thus expect the 1.1.1 libraries that you have installed to be called libcrypto.so.11 and libssl.so.11.

On my Ubuntu machine, I have the following libraries for the same reason:

user@laptop:~$ cd /usr/lib/x86_64-linux-gnu; ls -1 libcrypto.so.*
libcrypto.so.1.0.0
libcrypto.so.1.1

They come from two different .deb packages, both of which I have installed: libssl1.0.0 and libssl1.1.

Maybe it’s the same on RHEL?

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.