Help with installing Aerospike on Windows 10 via Windows Subsystem for Linux


#1

Hello,

I’m attempting to install Aerospike on my laptop to no avail. I’m running Windows 10 and using the Windows Subsystem for Linux (WSL) running Ubuntu 16.04 to install it.

To clarify, I know Aerospike doesn’t support Windows 10, which is why I’m using the WSL implementation to run it.

I followed the instructions found here: https://www.aerospike.com/docs/operations/install/linux/ubuntu

Everything works fine up to the ./asinstall part.

The problem I’m running into is that any time I run sudo service aerospike start, I get aerospike: unrecognized service returned in the console.

I checked the tar file to see if everything is extracted correctly. I also checked on stackoverflow to see if there was an error on my part. Following the instructions on stackoverflow didn’t remedy my issue.

I’d appreciate if anyone can help me troubleshoot this. Thanks.


#2

Could you share the output of the ‘./asinstall part’?

Also which package (tar file) did you download?


#3
    Checking dependencies
Installing tools
dpkg -i aerospike-tools-3.16.0.ubuntu16.04.x86_64.deb
(Reading database ... 76269 files and directories currently installed.)
Preparing to unpack aerospike-tools-3.16.0.ubuntu16.04.x86_64.deb ...
Unpacking aerospike-tools (3.16.0) over (3.16.0) ...
Setting up aerospike-tools (3.16.0) ...
Installing /opt/aerospike
Writing /usr/local/lib/python2.7/dist-packages/aerospike.pth
Adding python path /opt/aerospike/lib/python
Installing server
dpkg -i aerospike-server-community-4.4.0.5.ubuntu16.04.x86_64.deb
(Reading database ... 76269 files and directories currently installed.)
Preparing to unpack aerospike-server-community-4.4.0.5.ubuntu16.04.x86_64.deb ...
Unpacking aerospike-server-community (4.4.0.5-1) over (4.4.0.5-1) ...
Setting up aerospike-server-community (4.4.0.5-1) ...

#4

I downloaded aerospike-server-community-4.4.0.5-ubuntu16.04


#5

Could you try running:

sudo systemctl start aerospike

If it fails, what is the output of:

ls /opt/aerospike
ls /etc/aerospike
which asd

#6

sudo systemctl start aerospike returns

Failed to start aerospike.service: Launch helper exited with unknown return code 1 See system logs and ‘systemctl status aerospike.service’ for details.

I believe I remember reading on another forum that systemctl is part of systemd, which isn’t part of WSL.

ls /opt/aerospike returns bin data doc lib smd telemetry usr

ls /etc/aerospike returns irqbalance-ban.sh sample

which asd returns /usr/bin/asd


#7

Sorry, I don’t have a WSL environment.

You may try running asd directly (bypassing systemd’s unit files).

for more info on that run:

asd --help
sudo asd --config-file /etc/aerospike/aerospike.conf --foreground

#8

It looks like /etc/aerospike/aerospike.conf is missing.


#9

why not just run aerospike in docker or in a vm? WSL isn’t really meant for running daemons.


#10

Unsure why that would be missing… The default config can be found here:


#11

Hi,

Thanks for reaching out to me.

Docker on Windows requires Hyper-V, which isn’t available on the Home version (only Enterprise and Professional). There are some workarounds with the WSL to get Docker running, but I haven’t set it up yet.

I was able to get aerospike running via Vagrant, but I need access to a tool only available on Linux from a third-party, which is why I was trying to keep everything in-house, so to speak.

If you have any solutions, I’m all ears. I’m on a bit of a deadline, so I’m exploring other options.


#12

If you’re on a deadline, I wouldn’t mess with trying to get Aerospike going on WSL. Why not spin up a VM using Vagrant, as you did before, and just continue working on that vagrant machine? Is there something stopping you from installing that 3rd party tool there?


#13

I switched over to a Digital Ocean account to get everything up and running. The Vagrant box on Windows is having difficulty seeing it.

Are you guys planning on setting up Aerospike in a repo in the future? I’ve set up MySQL and MongoDB with no issues on WSL using Apt, and it works flawlessly.


#14

You can use apt to install aerospike packages, which you have technically done already by using the asinstall script.

You mentioned that ‘systemd’ doesn’t operate well with WSL, if that is the case you could try the Ubuntu 14.04 package which supports ‘System V’.


#15

That’s a good idea. Thanks for the advice.


#16

I run aerospike on WSL, but not as you were hoping to. As you might have already realized, WSL does not come with systemd and aerospike does not provide init.d script on platforms whose default is systemd. One option is to use a WSL Linux flavour where aerospike comes with an init.d script. i.e Centos 6, Debian 7 etc. The other option is to run aerospike yourself from /usr/bin/asd. That’s what I do. @kporter already gave the command to run aerospike (asd) from commandline in foreground.