Installation issue on SuSE linux (AER-5383)


#1

I downloaded the aerospike-server-community-3.10.0.3.tar.gz file and is having trouble to start the aerospike server. Here is the error i get when running aerospike start:

aerospike-server/share/libexec/aerospike-start: line 39: [: 18446744073709551615: integer expression expected error: start failed due to an error. Nov 11 2016 19:44:59 GMT: WARNING (config): (cfg.c:1298) line 32 :: reuse-address is deprecated - please remove

Can anyone please help?


#2

I’m also facing this problem. Anyone has a solution?


#3

Which linux distribution?


#4

Amazon Linux 2016.09


#5

Suse enterprise 11.3


#6

Please provide the output for the following:

sudo /sbin/sysctl -n kernel.shmmax

#7

@Caldas, just to clarify,

Are you also seeing:

aerospike-server/share/libexec/aerospike-start: line 39: [: 18446744073709551615: integer expression expected error: start failed due to an error.

We were not able to reproduce on Amazon Linux.

For:

Nov 11 2016 19:44:59 GMT: WARNING (config): (cfg.c:1298) line 32 :: reuse-address is deprecated - please remove

Remove the reference to reuse-address in aerospike.conf.


#8

The output of the command is 18446744073709551615.

Yes, i see the error you described.


#9

Seems the value returned by /sbin/sysctl -n kernel.shmmax exceeds the max int in bash.

As a workaround, modify aerospike-start and have the function set_shmmax return immediately as this check doesn’t really matter on community versions.


#10

I get another error:

error: start failed due to an error. Nov 14 2016 21:16:45 GMT: WARNING (config): (cfg.c:1298) line 32 :: reuse-address is deprecated - please remove


#11

The warning is inconsequential, you can remove the reuse-address from your aerospike.conf to get rid of that.

As for “error: start failed due to error” are there any other logs that may indicate what the error may be?


#12

Here is the error i get:

Nov 15 2016 15:52:58 GMT: INFO (config): (cfg.c:3386) Rack Aware mode not enabled Nov 15 2016 15:52:58 GMT: INFO (config): (cfg.c:3389) Node id bb9cc0314ec981c Nov 15 2016 15:52:58 GMT: CRITICAL (hb): (hb.c:1977) No multicast groups specified. Nov 15 2016 15:52:58 GMT: WARNING (as): (signal.c:153) SIGINT received, shutting down Nov 15 2016 15:52:58 GMT: WARNING (as): (signal.c:156) startup was not complete, exiting immediately


#13

This is the problem, please see our heartbeat configuration documentation. Currently your configuration is configured to use multicast but seems that multicast-group isn’t configured.