Newrelic plugin for Aerospike not reporting


#1

I have created a aerospike box from the amazon ami as mentioned on the documentation. Now i want to see the reports from it to new relic. I have installed the new relic plugin for x64 using npi and configured plugin.json. url: https://github.com/aerospike/newrelic-plugin

But i see no data reporting to newrelic. Licencekey is correct and below is my plugin.json.

{
  "agents": [
        {
      "host" : "127.0.0.1",
      "port" : "3000",
      "user" : "",
      "password" : "",
      "clusterName": "Aerospike"
    }
  ]
}

Since i am running a community edition i did not give any user/pass.

Any info on how to make this work would be good :smile:


#2

I’m having the same problem.


#3

Hmm my guess is the charts/metrics in Newrelic are hardcoded to a certain “clustername”, if we can guess the right clustername to use, we can get the graphs working.


#4

I have set the loglevel to debug and saw that the metrics are sent successfully and received a “200OK”.

If it is an issue with the clustername, the sending of metrics would return an error, correct?


#5

The metrics are being recorded by the Newrelic servers, but the graphs at Newrellic are configured for at clustername we don’t know.


#6

We have fixed the above issue. At the time of publishing the graphs we had specified the Cluster name in graph metric due to which, for all user accounts it searches for the same cluster name.
We have published the new changes. Please check the latest plugin update.


#7

Cool, thanks. Is it just me, or is this plugin generating a lot of load on the operating system and the Aerospike server it’s monitoring ?


#8

Thanks. The graphs have started plotting.

I do not see it creating load on the OS. But i do see some connections increase on aerospike server.

Now the current issue is i have two nodes, and i have installed plugin on one and its is reporting. If i install on the other and give the same Clustername, the graphs does not plot.

I tried tinkering with the host ip and clustername, but no luck.


#9

This plugin is creating a lot of connections to aerospike and not closing them. I stopped the plugin.


#10

We’ve resolved the issue of plugin opening too many connections to server.


#11

Nice. I checked it now it is fine.

There is one more thing. I am running AMC on one machine and i have 2 nodes with 4 cluster size. But the aerospike is not reporting the 2nd box data. I tried installing aerospike plugin on the second box and also giving the details of 2 in the config of first, Still it was not reporting.


#12

@shyamkumart We’ve introduced a new parameter “name” in config/plugin.json. This is a mandatory parameter the user has to provide, which associates each plugin with a name. With this, individual plugins are identified on newrelic and user can then see respective node data metrics on dashboard.


#13

@PratikJarande I have used the same and tested it which did not work out. In my former reply i referred to the same.

The config i am referring to is plugin.json itself.


#14

@shyamkumart From the information you’ve provided, we understand that you have a cluster with 4 nodes and on two nodes you have installed the plugin out of which the second node’s metric is not getting reported to newrelic, correct me if I’m wrong. Can you please tell us how have you configured the plugin on nodes. Have you also tried reinstalling the plugin on both nodes?