Not able to login using "admin":"admin" password in AQL

aql

#1

I am trying to login to aql using below command.

aql -Uadmin -P
Seed:         127.0.0.1
User:         admin
Config File:  /etc/aerospike/astools.conf /home/username/.aerospike/astools.conf 
Enter Password:

and using password as admin.

I get below error -

2018-07-23 06:03:21 WARN Failed to connect to seed 127.0.0.1 3000. AEROSPIKE_SECURITY_NOT_SUPPORTED AEROSPIKE_SECURITY_NOT_SUPPORTED from 127.0.0.1:3000

#2

Security has to be enabled in the config file first and its an Enterprise Edition feature.


#3

I disabled security in my /etc/aerospike/aerospike.conf file and restarted aerospike.

Yet, the same error.

I have access-control setup though as below -

service {
	paxos-single-replica-limit 1 # Number of nodes where the replica count is automatically reduced to 1.
	proto-fd-max 15000
	access-address 127.0.0.1
	access-address 192.168.100.6
}

Is that limited to enterprise edition too?


#4

You don’t use -U and -P options - just run aql direct. -U and -P are only valid when security is enabled. Nothing to do with access-address.

$ aql 
aql> help

#5

Thanks that solved!

What extra security layer does security configuration provides? why security is enterprise only? I mean, as an startup, we could also use aerospike and move to enterprise later|!


#6

If you are just starting - see these set of 3 intro videos - #2 is here: https://www.youtube.com/watch?v=PA7PGWphW8M&list=PLGo1-Ya-AEQDa32hFggyB0yIIOldxUFwv&index=2

Security - https://www.aerospike.com/docs/operations/configure/security these features are only available when you upgrade to Enterprise Edition.


#7

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.