Python package dependency for debian (.deb) based aerospike-tools installers

Python Package Dependency for Debian based tools

Problem Description

Aerospike Tools releases in between 3.27.1 and 3.31.0 support both python2 and python3.

However, the debian and ubuntu installers for those versions still include a dependency on the “python” package (python2). This should have been removed with the release of python3 support.

These aerospike-tools installers are bundled with server release versions 5.1.0.X and 5.2.0.X.

Solution

To fix a standalone tools install, upgrade to aerospike-tools-3.31.1 or later.

To workaround an aerospike server bundle install, use one of the following 2 options:

Option A

Install the “python” package (python2).

Example for ubuntu 20.04:

$ apt install python

Recommendation is for tools to use python2 at this point. If python3 usage is desired, the “python” bin path will need to resolve to python3 since it is checked first.

Option B

Instead of running the ./asinstall script, install aerospike-tools-3.31.1 and the server separately.

$ dpkg -i aerospike-tools-3.31.1*.deb

$ dpkg -i aerospike-server-*.deb

Keywords

DPKG DEB TOOLS PACKAGE PYTHON INSTALLATION DEBIAN UBUNTU

Timestamp

October 2020

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.