Redhat installation question, Python-Ply not available


#1

Hi, I am trying to install Aerospike in redhat after try the install command I can see it is failing because some of the dependenciesare not installed correctly.

Will you please help me to how to resolve this?

Thanks.

$sudo ./asinstall
Installing tools dependencies
**Installing py-bcrypt-0.4-4.el7.x86_64.rpm**
**warning: /home/ramaitra/aerospike-server-community-3.14.1.4-el7/aerospike-tools-deps/python-bcrypt/py-bcrypt-0.4-4.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY**
**error: Failed dependencies:**
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by py-bcrypt-0.4-4.el7.x86_64
Installing python-ply
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
**No package python-ply available.**
Error: Nothing to do
Installing tools
rpm -Uvh aerospike-tools-3.13.0.1-1.el7.x86_64.rpm
error: Failed dependencies:
        ld-linux-x86-64.so.2()(64bit) is needed by aerospike-tools-3.13.0.1-1.el7.x86_64
        ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) is needed by aerospike-tools-3.13.0.1-1.el7.x86_64
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by aerospike-tools-3.13.0.1-1.el7.x86_64
        libdl.so.2(GLIBC_2.2.5)(64bit) is needed by aerospike-tools-3.13.0.1-1.el7.x86_64
        libm.so.6(GLIBC_2.2.5)(64bit) is needed by aerospike-tools-3.13.0.1-1.el7.x86_64
        libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by aerospike-tools-3.13.0.1-1.el7.x86_64
        librt.so.1(GLIBC_2.2.5)(64bit) is needed by aerospike-tools-3.13.0.1-1.el7.x86_64
Installing server
rpm -Uvh aerospike-server-community-3.14.1.4-1.el7.x86_64.rpm
error: Failed dependencies:
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by aerospike-server-community-3.14.1.4-1.el7.x86_64
        libdl.so.2(GLIBC_2.2.5)(64bit) is needed by aerospike-server-community-3.14.1.4-1.el7.x86_64
        libm.so.6(GLIBC_2.2.5)(64bit) is needed by aerospike-server-community-3.14.1.4-1.el7.x86_64
        libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by aerospike-server-community-3.14.1.4-1.el7.x86_64
        librt.so.1(GLIBC_2.2.5)(64bit) is needed by aerospike-server-community-3.14.1.4-1.el7.x86_64

Here is the extracted files.

    $ls -l
    total 8428
    -rw-r--r-- 1 ramaitra ramaitra 5614904 Sep 16 00:35 aerospike-server-community-3.14.1.4-1.el7.x86_64.rpm
    -rw-r--r-- 1 ramaitra ramaitra 2970232 Sep 16 00:35 aerospike-tools-3.13.0.1-1.el7.x86_64.rpm
    drwxr-xr-x 7 ramaitra ramaitra    4096 Sep 16 00:35 aerospike-tools-deps
    -rwxr-xr-x 1 ramaitra ramaitra    1332 Sep 16 00:35 asinstall
    -rw-r--r-- 1 ramaitra ramaitra   11665 Sep 16 00:35 LICENSE
    -rw-r--r-- 1 ramaitra ramaitra    2132 Sep 16 00:35 SHA256SUMS