Scan doens't stop


#1

Hi, i have a problem with scan.

I was going to create a namepspace backup, so i used command:

“asbackup --node-list xxxxxxx:3000 --namespace ppchelp --directory /backups/aerospike”

After scan started, i pushed “Cntrl-z” cause i thought that scan have already run. But when some minutes later i decided to stop scan using command “asinfo -v ‘scan-abort-all:’” and start new dump process, i have seen this:

The top line it is the first dump process i’ve run. I used commands "asinfo -v ‘jobs:module=scan;cmd=kill-job;trid=’ " and “asinfo -v ‘scan-abort:id=’”, but it is still have status ACTIVE. For example, i run the second dump process and successfully stopped it. Now when i try to start dump process it gets status “active(ok)”, but in fact process speed = 0. I also tried to change new scan process priority to 5, but nothing have changed.

How can i remove scan and start dump? Thanks!


#2

Which version of Aerospike?

You can try;

  • increasing the number of scan threads.
  • running the abort all and waiting some time before beginning a new backup (if you haven’t tried giving it 20min or so)
  • In some extreme cases, need to recycle asd

http://www.aerospike.com/docs/operations/manage/scans/

Also, if you pushed this proc into a stopped bg state (using CTRL+Z) - you should be able to bring it back to the foreground so it can finish terminating by using fg %1 - http://tldp.org/LDP/abs/html/x9644.html - and then using CTRL+C