Trying to create a test namespace : Errors are not verbose

This is on version 4.9. I know it’s old. That’s my reality right now :slight_smile:

[root@aerospike-test-4 ~]# asinfo -h localhost  -U admin -P admin -v 'set-config:context=namespace;id=jeffm;replication-factor=1;memory-size=1M;storage-engine=memory'

Am I doing something wrong? Or is there a way to get more verbose logs? All that aerospike.log says is that this user was successfully authenticated.

  • set-config will only configure one config at a time - if you provide multiple dynamic configurations, only one will be set.
  • storage-engine isn’t dynamic.
  • replication-factor wasn’t dynamic in 4.9.

Does the namespace jeffm already exist? If not, also note that you cannot add namespaces dynamically.

If it does exist, then it should be attempting to set the memory-size for that namespace to 1M - this will fail if 1M is less than half the current configured memory-size.

Hi, thanks! The namespace doesn’t exist yet and for my needs right now that’s really all I have to know. A rolling restart is what I’ll need, so that’s what I’ll be doing :slight_smile:

Follow up tho as I’ve never dynamically configured namespaces: When using set-config does it have to be issued to every server, or is just one fine ?


It needs to be issued to every server - if you use asadm -e 'asinfo -v "set-config:..."' the command will be sent to all nodes in the target cluster.

If you need to persist the config setting, you have to edit the aerospike.conf on each node.

Ack. Thank you.

This topic was automatically closed 84 days after the last reply. New replies are no longer allowed.