Unable to establish a baseline when doing async writes

I have the Aerospike docker instance running on my local machine. My program is trying to update 1 million records. I am using the java client’s async mechanism as given in this example. i have 6 event loops and concurrency is set to 240, i.e, the concurrentMax variable of the example is set as 240.

Everytime I run the program I get a different measurement. The program takes anywhere between 63 seconds to 110 seconds. Why is there a significant difference every time I run it? There is nothing else running on my machine.

Could you describe the testing environment a bit more?

  1. Are you running the client and server from the same machine?
    1. You should avoid running the client and server on the same machine as they will compete for the same resources.
  2. Could you describe your local machine?
    1. If it is a laptop, I’d suggest testing are real hardware. I’ve found running benchmarks on my laptop to be unreliable. A common reason for unreliable results is thermal throttling.
1 Like

Yes, they are running on the same machine.

Yes, it is a laptop. 12 cores, 16 GB RAM.

i will run the tests again with your suggestions incorporated and get back to you. Thank:)

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.