Vagrant fails on OSX Yosemite


#1

Trying to bring up the Aerospike Vagrant VM on Mac OS X 10.10 and I keep hitting the following error:

Simmons-Air-2:aerospike-vm dsimmons$ vagrant up Bringing machine ‘default’ up with ‘virtualbox’ provider… ==> default: Importing base box ‘aerospike/centos-6.5’… ==> default: Matching MAC address for NAT networking… ==> default: Checking if box ‘aerospike/centos-6.5’ is up to date… ==> default: Setting the name of the VM: aerospike-vm_default_1418933377039_20148 ==> default: Clearing any previously set network interfaces… ==> default: Preparing network interfaces based on configuration… default: Adapter 1: nat ==> default: Forwarding ports… default: 3000 => 3000 (adapter 1) default: 8081 => 8081 (adapter 1) default: 22 => 2222 (adapter 1) ==> default: Running ‘pre-boot’ VM customizations… ==> default: Booting VM… ==> default: Waiting for machine to boot. This may take a few minutes… The guest machine entered an invalid state while waiting for it to boot. Valid states are ‘starting, running’. The machine is in the ’poweroff’ state. Please verify everything is configured properly and try again.

If the provider you’re using has a GUI that comes with it, it is often helpful to open that and watch the machine, since the GUI often has more helpful error messages than Vagrant can retrieve. For example, if you’re using VirtualBox, run vagrant up while the VirtualBox GUI is open. DSimmons-Air-2:aerospike-vm dsimmons$

If I look in VirtualBox, I see the following error: Failed to open a session for the virtual machine aerospike-vm_default_1418933377039_20148.

The virtual machine ‘aerospike-vm_default_1418933377039_20148’ has terminated unexpectedly during startup with exit code 1.

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Machine Interface: IMachine {22781af3-1c96-4126-9edf-67a020e0e858}

None of that is all that helpful in figuring out why it won’t start. Ideas?


#2

Hi,

Have you tried the suggestions found here: https://www.virtualbox.org/ticket/6930

Thanks Petter


#3

Thanks. A complete re-install of VirtualBox fixed it! I’m up and running!