Aerospike Backup/Restore

Hi, I am newbie in Aerospike. I have taken Aerospike backup its working but when i restoring its not. I used this link Backup/Restore I taking backup from this command and its working.

asbackup --host IP -n namespace --output-file - | gzip > as_backup_${date} When I tried to restore its showing me error after enter this command: cat as_backup_date.asb.gz | gunzip | asrestore --input-file - asrestore: unrecognized option '–input-file’ Usage: asrestore [options] -h [default 127.0.0.1]

Which version of asrestore are you using, and on what OS are you running Aerospike? Open a terminal, and provide the output of the following command:

$ asrestore --version
asrestore --version
directory is required.

Usage: asrestore [options]
-h <host> [default 127.0.0.1]
-p <port> [default 3000]
-U <user name> [default none]
-P[<password>] [default none]
-t <threads> [default 20]
-n <namespace> [default namespace is in backup files]
-d <directory> (required)
-u insert only missing records (existing records not updated)[default update]
-r create or replace records if it already exists (existing records will be replaced)[default update]
-B insert only specific bins [default all]
-v verbose
-g no check for generation [default false]
--usage show usage
asd --version
Aerospike Community Edition build 3.5.4
I think you are right this version not included this feature.

The –usage argument lists the supported commands for the version that you are using. It is good to check the available options before using a specific version.

1 Like

@shakthimaan I have upgraded Aerospike Version. Now its pretty good working. can tell me how can i get every record size, may be possible for every sets. what is the best way to stop migration and terminate Machine. I did stop aerospike and rest other machine cpu gone high about to 95%.

I am glad you were able to get it working. Please ask your other questions in the relevant category. This section is only for asbackup and asrestore. Thanks!

1 Like

For record object size, assuming you are storing in SSD or HDD, (n/a for memory storage), use objsz histogram. See: Confusion re. obj-size-hist-max for examples.

I have seen after restore it was working that time. there is one profile two sets but its restoring only one set. I already set ttl 0 and its showing most of failed values after another try. Am I anything doing wrong.

asrestore --input-file as_backup.asb --namespace name --bin-list set1,set2
asrestore -d /dir/ --namespace name

–verbos mode I tried these also but its not working. Encountered end of file (line 5702968, col 1) End of backup file reached Not closing shared file descriptor Job queue is empty

© 2015 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.