Aerospike cluster issues on community edition


#1

Hi All,

We had tried to set up aerospike cluster(3.12) community edition on our linux system which is running on virtual box.we have encountered below issues after setting up cluster. Issue 1 - Nodes get disconnected as soon as we added new node. Description - We have add new node through Add new node option provided in AMC. We got pop up saying node added successfully but with in few seconds it another pop up appeared saying cluster lost with the server.

Issue 2 - After setting up the cluster, internet connection got failed and i am unable to access internet if i am using network adapter as bridge adapter, and we are also unable to remove nodes from the cluster.

Cloud you please help with this regard. Thanks


#2

I think your second issue might be a VirtualBox problem. First because Aerospike is unlikely to have any sort of control over your network adapter, and second because it’s an issue I often have with VirtualBox: The bridge adapter fails when the host goes into sleep mode, and the only option is to restart the virtual machine.


#3

Any warning from Aerospike’s logs?


#4

same thought… i will brief you from where problem was started and what i have done to resolve that(unable to fix that), me and my friend installed Aerospike in our virtual machine, then we add each other in aerospike cluster using AMC add node option. After that we see two nodes in our cluster and data got migrated.but after some time problem got started net stop working with bridge adapter. then we have tried to remove node from cluster using ‘DUN’ commands but still nodes are appearing in cluster. I have uninstall my virtual box itself but when installed again and used bridge adapter , i can see my cluster with same node and internet is not working.


#5

Apr 11 2017 07:09:34 GMT: WARNING (info): (thr_info.c:4786) No network interface addresses detected for client access


#6

Could ip addr on the vm?

ip addr

The ‘dun’ commands were removed in 3.9.1.


#7

Hi Kporter, can you please explain how to remove node from cluster. i didn’t catch what you meant by ip addr on the vm