Aerospike touch command functionality on XDR setup

I have two geo sites on aerospike. The Sets inside my namespace are to be replicated across the two clusters runnign on two sites. I can see my XDR is running fine between the two sites . But some of the records are still not present on the other site. The xdr status seems ok. What can be the reason for that ? Secondly , I know about the touch command , if I use it on the site where I have the record present , it will be replicated to the other site too. But , what happens if at timestamp t0 it is discovered that record is not present at site 2. While I prepare the command at timestamp t1 , the data gets created on the other site too. Now , at timestamp2 if I run the “touch” command on site1 for that record , what is expected ?

There can be a variety of reasons for records to not be on the other side… It is hard to guess without logs or more details on the use case. Since XDR is an Enterprise Edition feature, you should be able to have someone on your side reach out to Aerospike Support.

Regarding your second question, is the question about what happens if the record is touched at the source site but before the touch happens, the record is created on the other site? If the record was created on the other site through XDR, shipping the same record multiple times should be just fine and the touch shouldn’t have any impact (you would send the same update twice).

Having said that, if the record was written through a different client, it would depend on the XDR configuration… Specifically, versions 5.X do provide a few different options for shipping records. You can check the bin policy documentation for some details.

© 2021 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.