After upgrading the aerospike from 6.2 to 6.4 I am not getting the metrics

In 6.2 version I am was gettting below metrices “aerospike_latencies_read_ms_bucket” “aerospike_latencies_read_ms_bucket”.But after upgrading to 6.4 I am not getting it. I have upgraded the promethues exporter from 1.8 to 1.12 exporter on both 6.2 and on 6.4 version in order to solve the issue but still 6.2 version is giving me the metrics but 6.4 don’t

Hi Pawan - I can’t think of any reason that would be. I tried using 1.14 exporter and 6.2 vs 6.4 version and was not able to reproduce. I don’t think this would be any difference – but worth noting. My only thought is you might need to ensure you have a workload that will populate the latency.

Thanks Adam, for the response, yes the issue was fixed.Actually in the initial installation of the aerospike this metric is not exposed unless I put some data on it. This was new findings for me.

currently I am facing 1 issue , using asadm tool from my local to connect with my cluster “asadm -h -h” It is showing me the nodes are online.But when I ran any command it says no aerospike cluster

There was a bug in asadm when connecting to community edition. Upgrade to Tools 10.0.1 and this will be resolved.

HI @Adam_Hevenor thanks for the help. We are having one more issue. Actually dev is inputing data on Aerospike with some TTL but these data are getting deleted automatically but there TTL are still valid. Means those data have TTL of 1 year but they are getting deleted in a month. Can you help me to understand is there any conf. issue on Aerospike? Or where I can check this

Sounds like you may have had evictions. Check this documentation page: Configuring Namespace Data Retention | Aerospike Documentation and don’t hesitate to reach out if any further questions. You can also look for articles about evictions in the knowledge base, for example: Aerospike Customer.