Afterburner Script Error


#1

After installed Aerospike server, I attempt to run afterburner script, then get this error:

root@ub1404-db:/opt/aerospike/bin# ./afterburner.sh
Configuring: core: 0 ETH: eth0  IRQ:  AFFINITY: 1
./afterburner.sh: line 57: /proc/irq//smp_affinity: No such file or directory

The smp_affinity files in directory /proc/irq:

root@ub1404-db:/opt/aerospike/bin# ll /proc/irq/*/smp_affinity

-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/0/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/10/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/11/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/12/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/13/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/14/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/15/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/1/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/2/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/3/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/40/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/41/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/42/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/43/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/44/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/45/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/46/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/4/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/5/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/6/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/7/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/8/smp_affinity
-rw------- 1 root root 0 Sep 19 12:53 /proc/irq/9/smp_affinity

#2

what version of Aerospike are you using please?


#3
root@ub1404-db:/opt/aerospike/bin# asd --version
Aerospike Community Edition build 3.6.0

I suffered this issue earlier this year, when I installed Aerospike server for the first time, on CentOS 6.6.

This time I installed it on Ubuntu 1404, and got the same issue.


#4

I’ve reproduced this and I’m now looking into what next steps are. I will revert on this thread


#5

I have raised a JIRA to flag this issue to our engineering team. The number is OPS-650, please keep a look out for it in our release notes.