Asd is not running!


#1

Post by gashcrash » Sat May 03, 2014 6:20 pm

Hi,

I am new to aerospike.

My current system details are as below:

Ubuntu : 13.10 Aerospike : 2.3.2

I installed aerospike server and when i give ‘sudo service aeropsike start’ comman i am getting this error. kernel.shmall too low, setting to 4G pages kernell.shmall = 4294967296 kernel.shmax too low, setting to 1GB kernell.shmall = 1073741824

  • asd is not running !

Kindly assist.

Thanks !


#2

Post by devops02 » Wed May 07, 2014 1:41 pm

humm…can you provided me with your config settings? and possible the last 1000 lines of your log file? To get a copy of the log file run the following command.

tail -f 1000 /var/log/cirtrusleaf.log

Also have you tried running it with the following command first to see if it gives you the same error?

/etc/init.d/citrusleaf start

  • Devops02

#3

Post by superman » Sun May 11, 2014 7:11 pm

i am having the same problem, did you find the solution to it ?

i got this error the very 1st time i tried to start the aerospike server. Hence i do not have a log file.


#4

Post by young » Mon May 12, 2014 8:21 am

Have you tried starting the server as root or with the sudo command? A log file should have started up. The default location of the log file is only writable by root, so this may have been the problem.