Asinfo --only-config-file /etc/aerospike/nodubug_aerospkie.conf doesn't work at all

when I try to use asinfo --only-config-file /etc/aerospike/nodubug_aerospkie.conf there is error: ERROR: Config file parse error: /etc/aerospike/nodubug_aerospkie.conf Found invalid character in key name: ‘{’. Try quoting the key name

Could you share the config file? In case it isn’t known, this option is looking for a ‘tools’ config file and not the server config file.


what I mean is: I feed the xxx.config to aerospike server but it always read the one that named aerospike.conf.

How can I use asinfo to let aerospike server read the other configuration file not just named aerospike.conf


Here is the contents of my configuration file:

# Aerospike database configuration file for use with systemd.

service {

paxos-single-replica-limit 1 # Number of nodes where the replica count is automatically reduced to 1.

proto-fd-max 15000


logging {

file /var/log/aerospike/aerospike.log {

context any info


file /opt/aerospike/data/logs/aerospike_critical.log {

context any critical



network {

service {

address any

port 3000


heartbeat {

mode multicast


port 9918

# To use unicast-mesh heartbeats, remove the 3 lines above, and see

# aerospike_mesh.conf for alternative.

interval 150

timeout 10


fabric {

port 3001


info {

port 3003



namespace test {

replication-factor 2

memory-size 10G

default-ttl 30d # 30 days, use 0 to never expire/evict.

# storage-engine memory

# To use file storage backing, comment out the line above and use the

# following lines instead.

storage-engine device {

file /opt/aerospike/data/4Thrd500.dat

filesize 1600G

#       data-in-memory true # Store data in memory in addition to file.

write-block-size 128K


asinfo doesn’t determine which configuration file the server will use. Which configuration file is defined by the method used to start the server, typically the SystemD unit file. These methods use the --config-file option of asd, see asd --help.