Asinfo how to set config


#1

Hi, I am doing some config change like

 asinfo -v 'set-config:context=service;proto-fd-max=150000'
~~~ -v set-config:context = service ~~~
Do not understand '=' in '-v set-config:context = service'
~~~ = 150000 --no_node_name ~~~
ERR: Do not understand 'proto-fd-max = 150000 --no_node_name'

I am getting above error for all set-config.

I am able to get config details with out error like

asinfo -v 'get-config:' -l | grep 'proto-fd'
proto-fd-idle-ms=10000
proto-fd-max=100000

Any help will be great


#2

we would normally use the aerospike admin function to set this across the cluster, as it needs to be set on all nodes in the cluster. The below should work fine for you:

asadm -e "asinfo -v 'set-config:context=service;proto-fd-max=150000'"

or the single command would be:

asinfo -v 'set-config:context=service;proto-fd-max=150000'

#3

Yes , is working after using asadmin

So as per my understanding we have to use asadmin if we want to change in entire cluster. If we want to change on single node we should specify node name.

Thanks for your help.


#4

@Srikanth_Reddy … The error that you are seeing in asinfo was a known bug in the tools package released earlier this year and was fixed in tools 3.11.1.

Can you confirm if an upgrade fixes your issue? http://www.aerospike.com/download/tools/notes.html#3.12.0


#5

Hi,

How to check which asinfo version i am using like

asinfo --version
usage: asinfo [-h HOST] [-p PORT] [-t TLS_NAME] [-U USER] [-P [PASSWORD]]
              [-v VALUE] [-l] [-u] [--tls_enable] [--tls_encrypt_only]
              [--tls_cafile TLS_CAFILE] [--tls_capath TLS_CAPATH]
              [--tls_protocols TLS_PROTOCOLS]
              [--tls_cipher_suite TLS_CIPHER_SUITE]
              [--tls_keyfile TLS_KEYFILE] [--tls_certfile TLS_CERTFILE]
              [--tls_cert_blacklist TLS_CERT_BLACKLIST] [--tls_crl_check]
              [--tls_crl_check_all]
asinfo: error: unrecognized arguments: --version
 /usr/bin/asinfo --V
usage: asinfo [-h HOST] [-p PORT] [-t TLS_NAME] [-U USER] [-P [PASSWORD]]
              [-v VALUE] [-l] [-u] [--tls_enable] [--tls_encrypt_only]
              [--tls_cafile TLS_CAFILE] [--tls_capath TLS_CAPATH]
              [--tls_protocols TLS_PROTOCOLS]
              [--tls_cipher_suite TLS_CIPHER_SUITE]
              [--tls_keyfile TLS_KEYFILE] [--tls_certfile TLS_CERTFILE]
              [--tls_cert_blacklist TLS_CERT_BLACKLIST] [--tls_crl_check]
              [--tls_crl_check_all]
asinfo: error: unrecognized arguments: --V

#6

Can you try asinfo -v version
(–> that yields the Server version.) Aerospike-tools package version can be found using: dpkg -l aerospike-tools in Ubuntu rpm -qi aerospike-tools in RHEL Tools package release notes are at: http://www.aerospike.com/download/tools/notes.html I think AQL and asinfo don’t have separate version numbers though aql does support aql --version but yields the tools package version. asadm does have its own version number. asadm --version


#7

I would like to change the heartbeat.mesh-seed-address-port setting. I would like to remove an old server and add a new one. How do I do that, since heartbeat.mesh-seed-address-port is an array of values?

Thanks


#8

mesh-seed-address-port is one entry per node you want to discover address port pair. you can have multiple entries in the config file. if you want to remove an old server, take its entries out of the config file from rest of the servers while they are live. the config is only read when servers start. in the new server add entries for a few of the nodes in the remaining cluster. when it starts it will join the cluster. you need minimum one entry to join the cluster. you can also make a live individual node join the cluster using the asinfo tip command. also look up tip-clear and asinfo -v ‘services-alumni-reset’ to clear unused nodes from live cluster

http://www.aerospike.com/docs/operations/configure/network/heartbeat

http://www.aerospike.com/docs/reference/info


#9

@pgupta Thanks for the help.

Adding a node works fine, it connect to the cluster without any issues. Also the dead node is gone from the amc.

I’ve removed the dead node from all the servers and ran asinfo -v ‘services-alumni-reset’ in adadm but the warnings are still there. I looks like as is still pinging the dead node.

I still have logs full of this warnings Apr 22 2017 10:39:38 GMT: WARNING (cf:socket): (socket.c:764) Error while connecting FD 166: 111 (Connection refused) Apr 22 2017 10:39:38 GMT: WARNING (cf:socket): (socket.c:823) Error while connecting socket to 192.168.201.104:3002

The version I’m using is 3.11.0.2


#10

first do tip-clear then alumni reset editing the config file is so that if you restart any good node in the future it does not look for the removed node.


#11

Oh, I overlooked the tip-clear part.

Works like a charm. Thanks