Cannot install AMC (Aerospike Management Console) on Debian 7


#1

Hi,

Why does the amc documentation promote installing all packages separately(http://www.aerospike.com/docs/amc/install/linux/ubuntu/), when the control file in the .deb has a depends on all of them.

Can somebody do a apt-get install aerospike-amc-community and get it installed cause the dependencies should get resolved automatically, if the sources.list are correct. I downloaded the .deb and put it in a private repo.

I followed the docs and amc gets installed successfully, if i install everything separately as the docs say, but when i do a apt-get install it fails with error

“Depends: Python (>= 2.6) but it is not installable”

even though python-2.7 is already installed by default on wheezy.

Is this a bug or am i doing something wrong?


#2

When you run: python --version is it 2.7? I think the default is 3.x in Debian 7. Also does Debian 7 use systemd? AMC may also have problems with that too.


#3

Python Version is 2.7.3 and systemd is not installed.


#4

AMC requires python 2.6+ and doesn’t yet support python 3.


#5

@kporter: Did not understand, 2.7.3 is 2.6+ right? Also AMC works on the same box, if i install all dependencies separately.


#6

Sorry for the misunderstanding, I had read it as python version 2.7.3 and systemd is not installed.

Can we see which python interpreter is executed by default?

/usr/bin/env python --version

Could you elaborate?


#7

It’s a bug in packaging. There is a difference between Python and python :scream:

I’ve solved this issue by:

  1. Downloading .deb package.
  2. mkdir -p amc/DEBIAN
  3. dpkg -x amc.x86_64.deb amc
  4. dpkg -e amc.x86_64.deb amc/DEBIAN
  5. Edit amc/DEBIAN/control by replacing Python with python
  6. Build new package with: dpkg -b amc aerospike-amc-community_3.6.2_all

Now you have properly working aerospike-amc-community_3.6.2_all.deb with AMC.

I’d love this to be fixed in upstream, but apparently AMC doesn’t have public repository/bug tracker :frowning:


Aerospike Management Console (AMC) CE - Release 3.6.3 (September 25, 2015)
Aerospike Management Console (AMC) CE - Release 3.6.3 (September 25, 2015)
#8

Hi,

Yes, We will change Python to python in package information, though we are able to install AMC on Debian 7.8. Can you please specify OS version which you were using?

Thanks.


Aerospike Management Console (AMC) CE - Release 3.6.3 (September 25, 2015)
#9

Both Debian Wheezy and Jessie.

You can install downloaded package via dpkg -i amc.deb, but as it won’t find all the dependencies it’ll remain in semi-installed state.

With the fix everything works fine.


#10

@b_a_t,

Thanks for identifying the bug in packaging! :blush: We fixed it upstream (via JIRA ticket TOOLS-48) and just released it in Release 3.6.4 of the Aerospike Management Console.