Error Aerospike C client called from Lua


#1

After compiled the Lua client and started it i have error: "/usr/lib/libaerospike.so: undefined symbol: RAND_seed" tested with prepared packages and with the Git cloned source and no luck so far. Still same error. OS Ubuntu 14.04 64bit, Any help? Thanks Plamen


Calling Aerospike C Client from Lua
#2

Are LDFLAGS -lssl -lcrypto -lpthread added?


#3

@darisc were you able to solve this problem? I’m also getting the same error. Funny thing is that on centOS, the lua client works but not on Ubuntu 12+


#4
      I got it to work if you install libssl0.9.8 only and don't 

install libssl as what the ubuntu c client instructions say and symlink

sudo apt-get install libssl0.9.8
sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.0.9.8 /usr/lib/x86_64-linux-gnu/libcrypto.so

I’m too new to linux and C to know why this is the case.


#5

The library require libssl1.0.0.

Please verify that’s the version “apt-get install libssl-dev” installed the correct version. If not, “apt-get update” may be required.


#6

Thank you @wchu, it appears that the instructions for the ubuntu build is incorrect. It tells us to install 0.9.8


#7

Can you clarify where this instruction is seen? We will make the appropriate corrections. Thanks


#8

http://www.aerospike.com/docs/client/c/install/ubuntu12.html


#9

Updated the documentation. Thank you!