Facing issues while building aerospike libs with lua modules

#1
******$ ./build_osx.sh
1 warning generated.
Undefined symbols for architecture x86_64:
  "_FIPS_mode_set", referenced from:
      _as_tls_cleanup in libaerospike.a(as_tls.o)
  "_ev_async_send", referenced from:
      _as_event_execute in libaerospike.a(as_event_ev.o)
  "_ev_async_start", referenced from:
      _as_event_create_loop in libaerospike.a(as_event_ev.o)
      _as_event_register_external_loop in libaerospike.a(as_event_ev.o)
  "_ev_async_stop", referenced from:
      _as_ev_wakeup in libaerospike.a(as_event_ev.o)
  "_ev_break", referenced from:
      _as_ev_wakeup in libaerospike.a(as_event_ev.o)
  "_ev_io_start", referenced from:
      _as_event_command_write_start in libaerospike.a(as_event_ev.o)
      _as_ev_write in libaerospike.a(as_event_ev.o)
      _as_ev_tls_connect in libaerospike.a(as_event_ev.o)
      _as_event_connect in libaerospike.a(as_event_ev.o)
      _as_ev_callback_common in libaerospike.a(as_event_ev.o)
      _as_ev_read in libaerospike.a(as_event_ev.o)
  "_ev_io_stop", referenced from:
      _as_event_socket_timeout in libaerospike.a(as_event.o)
      _as_event_total_timeout in libaerospike.a(as_event.o)
      _as_event_query_complete in libaerospike.a(as_event.o)
      _as_event_batch_complete in libaerospike.a(as_event.o)
      _as_event_parse_error in libaerospike.a(as_event.o)
      _as_event_response_error in libaerospike.a(as_event.o)
      _as_event_command_parse_header in libaerospike.a(as_event.o)
      ...
  "_ev_loop_destroy", referenced from:
      _as_ev_worker in libaerospike.a(as_event_ev.o)
  "_ev_loop_new", referenced from:
      _as_event_create_loop in libaerospike.a(as_event_ev.o)
  "_ev_run", referenced from:
      _as_ev_worker in libaerospike.a(as_event_ev.o)
  "_ev_timer_again", referenced from:
      _as_event_command_execute_in_loop in libaerospike.a(as_event.o)
      _as_event_socket_timeout in libaerospike.a(as_event.o)
      _as_event_command_retry in libaerospike.a(as_event.o)
      _as_event_execute_from_delay_queue in libaerospike.a(as_event.o)
  "_ev_timer_start", referenced from:
      _as_event_command_execute_in_loop in libaerospike.a(as_event.o)
      _as_event_socket_timeout in libaerospike.a(as_event.o)
      _as_event_command_retry in libaerospike.a(as_event.o)
  "_ev_timer_stop", referenced from:
      _as_event_socket_timeout in libaerospike.a(as_event.o)
      _as_event_command_retry in libaerospike.a(as_event.o)
      _as_event_command_begin in libaerospike.a(as_event.o)
      _as_event_query_complete in libaerospike.a(as_event.o)
      _as_event_batch_complete in libaerospike.a(as_event.o)
      _as_event_parse_error in libaerospike.a(as_event.o)
      _as_event_socket_error in libaerospike.a(as_event.o)
      ...
  "_lua_tointegerx", referenced from:
      _connect in as_lua.o
      _put in as_lua.o
      _increment in as_lua.o
      _add_bins_to_rec in as_lua.o
      _add_bins_to_increment in as_lua.o

ld: symbol(s) not found for architecture x86_64
#2

Please do not double post the same question in different forums. Your original post is answered here: