How to skip secondary index build in startup

Hi, I have a problem with asp instance after create secondary index for set Firstly index was in status WO and I found here that if restart instance for fast build, but it is not true))

How to skip or disable secondary_index in startup? log… INFO (sindex): (secondary_index.c:4420) Sindex-ticker: 0%

asp version 4.3.0.7 community

Hey Stas,

Have you tried following these steps? https://docs.aerospike.com/docs/tools/aql/index_management.html#dropping-an-index

Cheers

Hi, Pisush

Thanks for your response I cannot drop my index now, because my instance still not started Usually, we don’t used second indexes and I don’t predict it before to make restart. :frowning: sadness I have 189ml obj And now How I understood than option for skip secondary index available only from 5.6 release

You should be able to remove the smd file for the secondary index prior to restart if you really want to remove the secondary index definition completely. Check this article: How do I synchronize all metadata across clusters?

Default location is /opt/aerospike/smd.

Meher, Good advice !!! It is what I need Thanks Meher

© 2021 Copyright Aerospike, Inc. | All rights reserved. Creators of the Aerospike Database.