Setting nsup period with aerospike kubernetes operator

i can’t find any docs on how to do this

Did you try under the namespace config?

Following the example on this page: Cluster Configuration Settings | Aerospike Documentation, I would expect it to simply be as follows (namespace level configuration parameter):

    namespaces:
      - name: test
        memory-size: 3000000000
        nsup-period: 120
        replication-factor: 2
        storage-engine:
          type: memory

Did this not work? (I didn’t try it, just guessing from the config example).