Setting stop-writes-noxdr does not work


#1

Hi,

according to the documentation http://www.aerospike.com/docs/operations/configure/cross-datacenter/replication/ the stop-writes-noxdr can be used to prevent Aerospike Server to accept writes if the XDR deamon is not working. But if I set it in the configuration file in the namespace context, the server won’t start up. The error messages is:

unknown config parameter name ‘stop-writes-noxdr’

Is it a parameter that can be just adjusted during runtime? It would be great to use it in the configuration files!

Thanks, Peter


#2

Hi Peter,

The stop-writes-noxdr parameter is defined in the xdr context.

Let us know if you have any further problems.


#3

I just realized the link you provided had the parameter in the wrong context. I will update the documentation appropriately. Thank you for bringing this to our attention.


#4

Hi,

thanks, then I will move that parameter to the xdr context.

Peter